Total servers: 3
Who's still around? (Forum Discussion ) by Rock April 21, 2019, 10:40:55 pm
62.84.226.59
Unknown
Unknown – 0lt
IP: 62.84.226.59
Game Mode:
Lives: 0
Max Kills: 0
Version: LieroX 0.56b
Players:
DE nonstop + voting
Liero v1.0 – 100lt
IP: 144.76.67.162
Game Mode: Death Match
Lives: 0
Max Kills: 15
Version: OpenLieroX 0.58 rc5
Players:
US nonstop + voting
Modern Warfare1.0 – 20lt
IP: 69.12.73.163
Game Mode: Death Match
Lives: 0
Max Kills: 15
Version: OpenLieroX 0.58 rc5
Players:
Pages: 1 [2] 3 4  All   Go Down

Author Topic: [Release] OpenLieroX 0.58 rc  (Read 30302 times)

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #20 on: February 13, 2010, 07:07:22 pm »
Have you copied all the DLLs?
Logged

Midnight

Re: [Release] OpenLieroX 0.58 rc
« Reply #21 on: February 13, 2010, 07:08:27 pm »
?

I downloaded it and extracted it to pc. what else?
Logged
Emma Watson <333

<3

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #22 on: February 13, 2010, 07:10:02 pm »
?

I downloaded it and extracted it to pc. what else?

No mixing with old files?
Logged

Midnight

Re: [Release] OpenLieroX 0.58 rc
« Reply #23 on: February 13, 2010, 07:10:48 pm »
No, just downloaded. No copied files from older betas or so.
Logged
Emma Watson <333

<3

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #24 on: February 13, 2010, 07:15:25 pm »
Hm, you are the first who reports such a problem for 0.58. That is pretty serious. Hurray for ****ing Microsoft Manifest ****ups.

Probably, what would fix the problem for you, is this patch: Download and install vcredist_x86.exe from here: http://www.microsoft.com/downloads/details.aspx?familyid=766a6af7-ec73-40ff-b072-9112bab119c2&displaylang=en

Anyway, not really a solution. We maybe should stop all MSVC support and concentrate really on a mingw solution. I hope that DC can solve this somehow (because I have nothing to do with Windows - and when I see such problem, I am really happy about it).
Logged

Midnight

Re: [Release] OpenLieroX 0.58 rc
« Reply #25 on: February 13, 2010, 07:18:19 pm »
Hm, i won't download any extras for windows just to play Lx. I once did and it ended not so kind..

Then i still play with buggy beta9, but all in all it works.
Logged
Emma Watson <333

<3

DarkCharlie

Re: [Release] OpenLieroX 0.58 rc
« Reply #26 on: February 13, 2010, 08:14:47 pm »
I can't solve that really, it's a mess. I vote for migrating to VS 2010 which doesn't use manifests anymore:

http://www.microsoft.com/visualstudio/en-us/try/default.mspx#download
Logged

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #27 on: February 13, 2010, 08:17:11 pm »
I can't solve that really, it's a mess. I vote for migrating to VS 2010 which doesn't use manifests anymore:

http://www.microsoft.com/visualstudio/en-us/try/default.mspx#download

Are all project files in 0.58 and 0.59 updated for MSVC 2010 and does everything works there (including Google Breakpad)?

Any other requirements? I would highly prefer it if I can use the official SDL (and others) dlls instead to have to build them by myself.
Logged

Kingston

Re: [Release] OpenLieroX 0.58 rc
« Reply #28 on: February 24, 2010, 11:08:05 pm »
It begins to download then stop after conclude this files (cfg,powerstuck..)
And it always happen, not only with rc3 but with all 0.59 betas (i guess it's some problem with link or...) very weird.Help me :(
Logged

Rakkula

Re: [Release] OpenLieroX 0.58 rc
« Reply #29 on: February 28, 2010, 04:29:48 pm »
Eeh... how come Gusanos doesn't work on rc3? How come liero factory revisited doesn't work on rc3 for me?
Logged
Opinions are like assholes: everyone has one, and they usually stink.
I started playing LX while you were on your mother's stomach

DarkCharlie

Re: [Release] OpenLieroX 0.58 rc
« Reply #30 on: February 28, 2010, 04:40:26 pm »
Gusanos was added in 0.59. And what exactly does not work in LFr?
Logged

Rakkula

Re: [Release] OpenLieroX 0.58 rc
« Reply #31 on: February 28, 2010, 07:45:52 pm »
Gusanos was added in 0.59. And what exactly does not work in LFr?
The map. I have the map in my levels file, but the game doesn't recognize it. If I host, it's not in the levels list, if I join other servers it states I don't have the map. The strange thing is, I can't download the level from the host either. I've already tried copying the level from other lx versions.
Logged
Opinions are like assholes: everyone has one, and they usually stink.
I started playing LX while you were on your mother's stomach

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #32 on: February 28, 2010, 07:52:54 pm »
Ah, I think you have this situation:

- You tried to download the map already earlier with OLX (via from-host-download or automatic download from filebase).
- That failed for some reason.
- You have a corrupted LFr map file now in your levels directory.
- OLX tries to load that level and fails.

OLX searches in My Documents / OpenLieroX / levels first. Because it finds the file there, it will not check any other file in OLX.exe dir / levels.

Actually,the bug here is that it has kept the corrupt LFr download and not deleted that automatically. Just delete it.

Can you make a bug report about that?
Logged

Rakkula

Re: [Release] OpenLieroX 0.58 rc
« Reply #33 on: March 01, 2010, 05:05:21 pm »
Can't be bothered.

Downloading levels from the host doesn't work either. Should it do it automatically?
Logged
Opinions are like assholes: everyone has one, and they usually stink.
I started playing LX while you were on your mother's stomach

Rakkula

Re: [Release] OpenLieroX 0.58 rc
« Reply #34 on: March 19, 2010, 12:48:47 pm »
lfr now works, so thanks. But... can I disable force minimum version?
Logged
Opinions are like assholes: everyone has one, and they usually stink.
I started playing LX while you were on your mother's stomach

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #35 on: March 19, 2010, 01:41:35 pm »
lfr now works, so thanks. But... can I disable force minimum version?

Yes, you can edit it in config file.

But why exactly do you want to support older versions? No serious bug/problem was ever reported for 0.58rc3. And it is known that physics is different in many older versions (esp physics is mostly broken in LX56 - behaves different on every system). You really should talk to your friends that they also update to keep a fair gameplay and to avoid problems. There is simply no reason not to do that.
Logged

Rakkula

Re: [Release] OpenLieroX 0.58 rc
« Reply #36 on: March 19, 2010, 02:29:32 pm »
Yes, you can edit it in config file.
Tried. I typed in LieroX/0.56 but the force minimum version was still on.
But why exactly do you want to support older versions?
I don't. But the fact was and still remains that not all will ever update. I want to be able to play with even those using older versions. Despite the fact that it might be a bit unfair.
Logged
Opinions are like assholes: everyone has one, and they usually stink.
I started playing LX while you were on your mother's stomach

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #37 on: March 19, 2010, 02:37:48 pm »
Yes, you can edit it in config file.
Tried. I typed in LieroX/0.56 but the force minimum version was still on.

Have you edited the correct options.cfg? OLX was not running while you edited/saved the file?

You can also set it in OLX itself in the console:
Code: [Select]
setVar GameOptions.Network.ForceMinVersion LieroX/0.56(Use tab-autocompletion for easier entering.)

Btw., maybe you have also some other setting activated which makes old versions impossible. There is also the setting ForceCompatibleConnect. Set that to false, then everybody can at least connect to your server and you see also the reason why they are incompatible.

Quote
But why exactly do you want to support older versions?
I don't. But the fact was and still remains that not all will ever update. I want to be able to play with even those using older versions. Despite the fact that it might be a bit unfair.

Maybe you should just force them to update. That would solve all their and your problems. I personally would not want to support such stupidness.
Logged

Bizkit

Re: [Release] OpenLieroX 0.58 rc
« Reply #38 on: June 27, 2010, 12:09:42 pm »


Downloaded rc3 for windows.

ALBERT! :D

Exact same thing happened for me after re-installing XP to my computer..

It's just plain annoying not being able to join 0.58 servers with older version. On the other hand, i had just got used to faster aim which i can't use with 0.57, for instance.

All this betafilterfukup makes me mad..

Logged

DarkCharlie

Logged
Pages: 1 [2] 3 4  All   Go Up