Total servers: 3
Who's still around? (Forum Discussion ) by Ruki July 16, 2019, 04:47:12 pm
Games nonstop + voting
Modern Warfare1.0 – 20lt
IP: 176.93.32.127
Game Mode: Death Match
Lives: 0
Max Kills: 15
Version: OpenLieroX 0.58 rc5
Players:
Backup server NL
Modern Warfare1.0 – 20lt
IP: 95.46.198.26
Game Mode: Death Match
Lives: 0
Max Kills: 15
Version: OpenLieroX 0.58 rc5
Players:
M0rtsHeaven
Modern Warfare1.0 – 20lt
IP: 84.251.82.159
Game Mode: Death Match
Lives: 0
Max Kills: 12
Version: OpenLieroX 0.58 rc5
Players:
Pages: 1 2 3 4 [All]   Go Down

Author Topic: [Release] OpenLieroX 0.58 rc  (Read 31477 times)

albert

[Release] OpenLieroX 0.58 rc
« on: January 21, 2010, 06:36:04 am »
Heya,

I am proud to announce the first stable release of the 0.58 version.

For some more details about what has changed between 0.57 and 0.58, and also some details about the development process of 0.58 itself, take a look here:
http://www.openlierox.net/forum/index.php/topic,12642.msg198750.html#msg198750

Here a rough overview about the changes of the latest beta (0.58 beta9) and the 0.58 rc2:

- many crashes fixed
- somewhat better performance
- tooltip in chat for userinfo disappears correctly
- possibility to disable weapon combos
- some new default settings (only for those who start OLX for the first time)

Download here:
http://www.openlierox.net/downloads/
« Last Edit: February 05, 2010, 11:31:23 pm by albert »
Logged

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #1 on: February 05, 2010, 11:32:31 pm »
A second stable release: 0.58 rc2

Some crashes fixed, and setting minimum forced version to OpenLieroX 0.58 rc1 by default.
Logged

k00man

Re: [Release] OpenLieroX 0.58 rc
« Reply #2 on: February 09, 2010, 04:23:16 pm »
What should I put on config file to allow everyone join my server, to not force min version?
Logged
Check out my level: Warriors Stronghold

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #3 on: February 09, 2010, 04:24:52 pm »
Just tell the other people to download the new version.
Logged

k00man

Re: [Release] OpenLieroX 0.58 rc
« Reply #4 on: February 09, 2010, 04:44:39 pm »
Just tell the other people to download the new version.

They simply wont.

Could you tell me now what I should put after forceminversion to allow everyone join my server, even 0.56 users?
Logged
Check out my level: Warriors Stronghold

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #5 on: February 09, 2010, 04:55:17 pm »
Just force them to update. Read some other threads here at LXA about the reasons why we should force everybody to update.

If they don't want to update, don't play with them. So they simply must update because there simply wont be anybody who plays with them anymore. We may even modify the master servers in the future so it wont accept old servers anymore.
Logged

Rakkula

Re: [Release] OpenLieroX 0.58 rc
« Reply #6 on: February 09, 2010, 04:58:54 pm »
We may even modify the master servers in the future so it wont accept old servers anymore.
Don't you think that might be a bit too extreme? I'd hack your new version, in that case, to make strafe universal and implement faster aim.
Logged
Opinions are like assholes: everyone has one, and they usually stink.
I started playing LX while you were on your mother's stomach

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #7 on: February 09, 2010, 05:02:02 pm »
We may even modify the master servers in the future so it wont accept old servers anymore.
Don't you think that might be a bit too extreme? I'd hack your new version, in that case, to make strafe universal and implement faster aim.

How much servers do you actually have seen where strafing is not allowed? Because on most servers, it is allowed anyway (because that is the default setting and most people don't change that).

And why aren't you just starting your own server (or dedicated server, it's for free, ask DC for access) where you allow strafing? Strafing should also be allowed on all of the current dedicated servers.
Logged

Rakkula

Re: [Release] OpenLieroX 0.58 rc
« Reply #8 on: February 09, 2010, 05:12:40 pm »
How much servers do you actually have seen where strafing is not allowed?
Well, usually when playing with older players, they use an old version in which strafe isn't allowed. It's not just quantity, you know. In a cw against a clan with older players, disallowed strafe will ruin my game.
And why aren't you just starting your own server where you allow strafing?
I host a server with allowed strafe. However, aiming's another issue. b4 has faster aiming and I can't aim properly with new betas.
Logged
Opinions are like assholes: everyone has one, and they usually stink.
I started playing LX while you were on your mother's stomach

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #9 on: February 09, 2010, 05:40:15 pm »
How much servers do you actually have seen where strafing is not allowed?
Well, usually when playing with older players, they use an old version in which strafe isn't allowed. It's not just quantity, you know. In a cw against a clan with older players, disallowed strafe will ruin my game.

Ok, I can make a new 0.58 release where it will always be activated if you play on old servers.

And why aren't you just starting your own server where you allow strafing?
I host a server with allowed strafe. However, aiming's another issue. b4 has faster aiming and I can't aim properly with new betas.

I also think the aiming is too slow. I probably will make a further release where you can just configure the aim speed yourself (clientside, i.e. everybody can have his prefered setting). I will add an option though that the server can force people to have the LX56-aimspeed, which would be disabled by default.
Logged

Rakkula

Re: [Release] OpenLieroX 0.58 rc
« Reply #10 on: February 09, 2010, 06:35:02 pm »
Ok, I can make a new 0.58 release where it will always be activated if you play on old servers.
Awesome!
I also think the aiming is too slow. I probably will make a further release where you can just configure the aim speed yourself (clientside, i.e. everybody can have his prefered setting). I will add an option though that the server can force people to have the LX56-aimspeed, which would be disabled by default.
At first sight I like the idea. However, aiming in lx isn't like in mouse aiming games: once you get accustomed to one aim speed, re-adapting takes a lot longer. For instance, I can only play with b4's aiming speed. Simply trying to aim on 0.59 makes me cry.
Logged
Opinions are like assholes: everyone has one, and they usually stink.
I started playing LX while you were on your mother's stomach

IRC

Re: [Release] OpenLieroX 0.58 rc
« Reply #11 on: February 09, 2010, 06:56:04 pm »
Right here we go again, it starts, but immediately says "Could not load fonts"
Logged
Cop is my legacy.

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #12 on: February 09, 2010, 06:58:11 pm »
Right here we go again, it starts, but immediately says "Could not load fonts"

Be sure that you have copied all DLLs over.
Logged

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #13 on: February 10, 2010, 04:27:59 am »
Another release: 0.58 rc3

Change log:
- Strafing is always allowed on <=0.57 beta5 servers.
- Aim speed is configureable and faster by default. It is also clientside, i.e. everybody can have the setting he prefer. In detail, you have now these new (client-side) options:
** AimAcceleration
** AimMaxSpeed
** AimFriction
** AimLikeLX56 (this is more complex - the way the friction is handled is slightly different; it has no effect on the acceleration and maxspeed, though)
- new feature/option (serverside): FullAimAngle. If enabled, you can also aim straight down. As it is not sure yet if the majority of people will like this, it is disabled for now. This may change in a further release if I am getting positive feedback for it.
- new option (clientside): CrosshairDistance
- fixed some very rare crashes
Logged

Legend

Re: [Release] OpenLieroX 0.58 rc
« Reply #14 on: February 10, 2010, 08:48:34 am »
Quote
We may even modify the master servers in the future so it wont accept old servers anymore.
My opinion only, but when it comes to such radical manoeuvres I would like to have some sort of poll take place. Disabling the versions just like that will surely enrage people, whatever good reasons there were behind it. Better yet, somehow tweak Path 2008 to work along with the newest betas so we old farts won't go to rebellion.
Logged

k00man

Re: [Release] OpenLieroX 0.58 rc
« Reply #15 on: February 10, 2010, 10:03:22 pm »
Another release: 0.58 rc3

Change log:
- Strafing is always allowed on <=0.57 beta5 servers.
- Aim speed is configureable and faster by default. It is also clientside, i.e. everybody can have the setting he prefer. In detail, you have now these new (client-side) options:
** AimAcceleration
** AimMaxSpeed
** AimFriction
** AimLikeLX56 (this is more complex - the way the friction is handled is slightly different; it has no effect on the acceleration and maxspeed, though)
- new feature/option (serverside): FullAimAngle. If enabled, you can also aim straight down. As it is not sure yet if the majority of people will like this, it is disabled for now. This may change in a further release if I am getting positive feedback for it.
- new option (clientside): CrosshairDistance
- fixed some very rare crashes

This is good.

I really like that I can optimize my own aimspeed and all that. You should just put these settings used to edit your aimspeed to options, not to server settings. Or does these settings force other players in your server have same aimspeed as host (that would be bad)?

And leave abitility to aim straight down off as default on further releases. I tried some games with abitility to aim down and it sucked.
Logged
Check out my level: Warriors Stronghold

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #16 on: February 10, 2010, 11:21:56 pm »
Quote
You should just put these settings used to edit your aimspeed to options, not to server settings. Or does these settings force other players in your server have same aimspeed as host (that would be bad)?

No, it's client-side. I fully agree that this should be moved to the general options dialog. I just didn't had the time to do it. Can somebody else (you?) do it?
Logged

Rakkula

Re: [Release] OpenLieroX 0.58 rc
« Reply #17 on: February 11, 2010, 01:11:36 pm »
How the hell am I supposed to change my aim speed? Can't find the options log where to do this.
Logged
Opinions are like assholes: everyone has one, and they usually stink.
I started playing LX while you were on your mother's stomach

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #18 on: February 11, 2010, 01:12:52 pm »
How the hell am I supposed to change my aim speed? Can't find the options log where to do this.

In game settings, set to very advanced, under Other-section. Or in config file, under Game, all those Aim* settings. Or set the variables via console: setVar GameOptions.Game.Aim...
Logged

Midnight

Re: [Release] OpenLieroX 0.58 rc
« Reply #19 on: February 13, 2010, 07:06:21 pm »


Downloaded rc3 for windows.

ALBERT! :D
Logged
Emma Watson <333

<3

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #20 on: February 13, 2010, 07:07:22 pm »
Have you copied all the DLLs?
Logged

Midnight

Re: [Release] OpenLieroX 0.58 rc
« Reply #21 on: February 13, 2010, 07:08:27 pm »
?

I downloaded it and extracted it to pc. what else?
Logged
Emma Watson <333

<3

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #22 on: February 13, 2010, 07:10:02 pm »
?

I downloaded it and extracted it to pc. what else?

No mixing with old files?
Logged

Midnight

Re: [Release] OpenLieroX 0.58 rc
« Reply #23 on: February 13, 2010, 07:10:48 pm »
No, just downloaded. No copied files from older betas or so.
Logged
Emma Watson <333

<3

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #24 on: February 13, 2010, 07:15:25 pm »
Hm, you are the first who reports such a problem for 0.58. That is pretty serious. Hurray for ****ing Microsoft Manifest ****ups.

Probably, what would fix the problem for you, is this patch: Download and install vcredist_x86.exe from here: http://www.microsoft.com/downloads/details.aspx?familyid=766a6af7-ec73-40ff-b072-9112bab119c2&displaylang=en

Anyway, not really a solution. We maybe should stop all MSVC support and concentrate really on a mingw solution. I hope that DC can solve this somehow (because I have nothing to do with Windows - and when I see such problem, I am really happy about it).
Logged

Midnight

Re: [Release] OpenLieroX 0.58 rc
« Reply #25 on: February 13, 2010, 07:18:19 pm »
Hm, i won't download any extras for windows just to play Lx. I once did and it ended not so kind..

Then i still play with buggy beta9, but all in all it works.
Logged
Emma Watson <333

<3

DarkCharlie

Re: [Release] OpenLieroX 0.58 rc
« Reply #26 on: February 13, 2010, 08:14:47 pm »
I can't solve that really, it's a mess. I vote for migrating to VS 2010 which doesn't use manifests anymore:

http://www.microsoft.com/visualstudio/en-us/try/default.mspx#download
Logged

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #27 on: February 13, 2010, 08:17:11 pm »
I can't solve that really, it's a mess. I vote for migrating to VS 2010 which doesn't use manifests anymore:

http://www.microsoft.com/visualstudio/en-us/try/default.mspx#download

Are all project files in 0.58 and 0.59 updated for MSVC 2010 and does everything works there (including Google Breakpad)?

Any other requirements? I would highly prefer it if I can use the official SDL (and others) dlls instead to have to build them by myself.
Logged

Kingston

Re: [Release] OpenLieroX 0.58 rc
« Reply #28 on: February 24, 2010, 11:08:05 pm »
It begins to download then stop after conclude this files (cfg,powerstuck..)
And it always happen, not only with rc3 but with all 0.59 betas (i guess it's some problem with link or...) very weird.Help me :(
Logged

Rakkula

Re: [Release] OpenLieroX 0.58 rc
« Reply #29 on: February 28, 2010, 04:29:48 pm »
Eeh... how come Gusanos doesn't work on rc3? How come liero factory revisited doesn't work on rc3 for me?
Logged
Opinions are like assholes: everyone has one, and they usually stink.
I started playing LX while you were on your mother's stomach

DarkCharlie

Re: [Release] OpenLieroX 0.58 rc
« Reply #30 on: February 28, 2010, 04:40:26 pm »
Gusanos was added in 0.59. And what exactly does not work in LFr?
Logged

Rakkula

Re: [Release] OpenLieroX 0.58 rc
« Reply #31 on: February 28, 2010, 07:45:52 pm »
Gusanos was added in 0.59. And what exactly does not work in LFr?
The map. I have the map in my levels file, but the game doesn't recognize it. If I host, it's not in the levels list, if I join other servers it states I don't have the map. The strange thing is, I can't download the level from the host either. I've already tried copying the level from other lx versions.
Logged
Opinions are like assholes: everyone has one, and they usually stink.
I started playing LX while you were on your mother's stomach

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #32 on: February 28, 2010, 07:52:54 pm »
Ah, I think you have this situation:

- You tried to download the map already earlier with OLX (via from-host-download or automatic download from filebase).
- That failed for some reason.
- You have a corrupted LFr map file now in your levels directory.
- OLX tries to load that level and fails.

OLX searches in My Documents / OpenLieroX / levels first. Because it finds the file there, it will not check any other file in OLX.exe dir / levels.

Actually,the bug here is that it has kept the corrupt LFr download and not deleted that automatically. Just delete it.

Can you make a bug report about that?
Logged

Rakkula

Re: [Release] OpenLieroX 0.58 rc
« Reply #33 on: March 01, 2010, 05:05:21 pm »
Can't be bothered.

Downloading levels from the host doesn't work either. Should it do it automatically?
Logged
Opinions are like assholes: everyone has one, and they usually stink.
I started playing LX while you were on your mother's stomach

Rakkula

Re: [Release] OpenLieroX 0.58 rc
« Reply #34 on: March 19, 2010, 12:48:47 pm »
lfr now works, so thanks. But... can I disable force minimum version?
Logged
Opinions are like assholes: everyone has one, and they usually stink.
I started playing LX while you were on your mother's stomach

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #35 on: March 19, 2010, 01:41:35 pm »
lfr now works, so thanks. But... can I disable force minimum version?

Yes, you can edit it in config file.

But why exactly do you want to support older versions? No serious bug/problem was ever reported for 0.58rc3. And it is known that physics is different in many older versions (esp physics is mostly broken in LX56 - behaves different on every system). You really should talk to your friends that they also update to keep a fair gameplay and to avoid problems. There is simply no reason not to do that.
Logged

Rakkula

Re: [Release] OpenLieroX 0.58 rc
« Reply #36 on: March 19, 2010, 02:29:32 pm »
Yes, you can edit it in config file.
Tried. I typed in LieroX/0.56 but the force minimum version was still on.
But why exactly do you want to support older versions?
I don't. But the fact was and still remains that not all will ever update. I want to be able to play with even those using older versions. Despite the fact that it might be a bit unfair.
Logged
Opinions are like assholes: everyone has one, and they usually stink.
I started playing LX while you were on your mother's stomach

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #37 on: March 19, 2010, 02:37:48 pm »
Yes, you can edit it in config file.
Tried. I typed in LieroX/0.56 but the force minimum version was still on.

Have you edited the correct options.cfg? OLX was not running while you edited/saved the file?

You can also set it in OLX itself in the console:
Code: [Select]
setVar GameOptions.Network.ForceMinVersion LieroX/0.56(Use tab-autocompletion for easier entering.)

Btw., maybe you have also some other setting activated which makes old versions impossible. There is also the setting ForceCompatibleConnect. Set that to false, then everybody can at least connect to your server and you see also the reason why they are incompatible.

Quote
But why exactly do you want to support older versions?
I don't. But the fact was and still remains that not all will ever update. I want to be able to play with even those using older versions. Despite the fact that it might be a bit unfair.

Maybe you should just force them to update. That would solve all their and your problems. I personally would not want to support such stupidness.
Logged

Bizkit

Re: [Release] OpenLieroX 0.58 rc
« Reply #38 on: June 27, 2010, 12:09:42 pm »


Downloaded rc3 for windows.

ALBERT! :D

Exact same thing happened for me after re-installing XP to my computer..

It's just plain annoying not being able to join 0.58 servers with older version. On the other hand, i had just got used to faster aim which i can't use with 0.57, for instance.

All this betafilterfukup makes me mad..

Logged

DarkCharlie

Logged

Bizkit

Re: [Release] OpenLieroX 0.58 rc
« Reply #40 on: June 27, 2010, 08:17:03 pm »
Try installing this:
http://www.microsoft.com/downloads/details.aspx?FamilyID=9b2da534-3e03-4391-8a4d-074b9f2bc1bf&displaylang=en

Apparently downloading that thingy didn't help..

Or should I put it into some particular folder?

0.59 and 0.58 rc1 give the same error report: "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem".

Confusing thing is that my former XP used to run rc3 and all the rest of the betas just fine. Can't figure out what's so different this time.
Logged

albert

Re: [Release] OpenLieroX 0.58 rc
« Reply #41 on: June 27, 2010, 08:19:18 pm »
Try also this:
http://www.microsoft.com/downloads/details.aspx?familyid=766a6af7-ec73-40ff-b072-9112bab119c2&displaylang=en

It probably would also work if you install all WinXP updates (which I would anyway recommend if you use WinXP).
Logged

Bizkit

Re: [Release] OpenLieroX 0.58 rc
« Reply #42 on: June 27, 2010, 08:22:04 pm »
Try also this:
http://www.microsoft.com/downloads/details.aspx?familyid=766a6af7-ec73-40ff-b072-9112bab119c2&displaylang=en

It probably would also work if you install all WinXP updates (which I would anyway recommend if you use WinXP).

Oh snap, that's probably the reason. Just noticed that updates are yet to be ready.

Big thanks for help!
Logged

Ahmed

Re: [Release] OpenLieroX 0.58 rc
« Reply #43 on: September 15, 2010, 02:02:24 am »
Here are my issues.

1). When I start the game the mouse moves very slughishly. Weird mystery lag I suppose.
2). FPS is 30ish.
3).. no other real problems.


.59 eliminates the slughish mouse but the fps is still super low, I can play in 100% but it's weird and 20% well that is just unplayable.

Does not happen in .56, beta 1 (which my fps was actually increased) or beta 3 (so it shouldn't be a gui problem).

I can't switch till that FPS is fixed.

Logged
Learning about chemistry all day is more fun than anything... sorry LieroX.

DarkCharlie

Re: [Release] OpenLieroX 0.58 rc
« Reply #44 on: September 15, 2010, 07:33:35 pm »
Here are my issues.

1). When I start the game the mouse moves very slughishly. Weird mystery lag I suppose.
2). FPS is 30ish.
3).. no other real problems.


.59 eliminates the slughish mouse but the fps is still super low, I can play in 100% but it's weird and 20% well that is just unplayable.

Does not happen in .56, beta 1 (which my fps was actually increased) or beta 3 (so it shouldn't be a gui problem).

I can't switch till that FPS is fixed.

Thanks for the report. Could you also add your computer specs (RAM, processor and graphics card)?
Logged

Ahmed

Re: [Release] OpenLieroX 0.58 rc
« Reply #45 on: September 17, 2010, 02:52:14 am »
Here are my issues.

1). When I start the game the mouse moves very slughishly. Weird mystery lag I suppose.
2). FPS is 30ish.
3).. no other real problems.


.59 eliminates the slughish mouse but the fps is still super low, I can play in 100% but it's weird and 20% well that is just unplayable.

Does not happen in .56, beta 1 (which my fps was actually increased) or beta 3 (so it shouldn't be a gui problem).

I can't switch till that FPS is fixed.

Thanks for the report. Could you also add your computer specs (RAM, processor and graphics card)?

xp, 512 ram, old graphics card. I mean if it worked on it before it shouldn't be such a huge issue right..?
Logged
Learning about chemistry all day is more fun than anything... sorry LieroX.

kokbira

  • Gi Joe Brown Brazillian Rope-Flying Ant
  • LXA Part Time Adapt
  • *****
  • Schwartz: +23/-6
  • Offline Offline
  • Posts: 529
  • 3908 credits
  • View Inventory
  • Send Money To kokbira
  • ex-player (ex-Flip and ex-s00t clan member)
    • WWW
Re: [Release] OpenLieroX 0.58 rc
« Reply #46 on: October 10, 2011, 05:52:13 am »
http://pkgs.org/download/openlierox
 Arch Linux Arch Linux Community: Slackware 13.1 Slacky: Ubuntu 11.04 GetDeb Games: Ubuntu 10.04 LTS GetDeb Games:
-------------

Fedora Rawhide Fedora: Fedora 16 Fedora: Fedora 14 Fedora: Mandriva Cooker Mandriva Contrib Release: Mandriva 2010 Mandriva Contrib Release:
Logged

Gaston

Re: [Release] OpenLieroX 0.58 rc
« Reply #47 on: December 10, 2011, 04:57:44 pm »
I've searched and couldn't find it anywhere, so I'll just ask here:

How does one make a "high resolution level"? Is there a new levelmaker that does this? Is there a secret aspect to the JasonB? Or is ot something that has to be done by manually pasting png files together or smth?
Logged
26 Mars 2007
Belle: woah, is that a neatly snuck in sexproposition? Could I ask you to take of your pants?

pelya

Re: [Release] OpenLieroX 0.58 rc
« Reply #48 on: December 11, 2011, 06:35:10 am »
Download the new level compiler, it should do all the necessary stuff.
You should use 0.59-beta-something to play it, however hi-res levels are backward-compatible to the old LX as well - it will load only the low-res part.
Logged

Gaston

Re: [Release] OpenLieroX 0.58 rc
« Reply #49 on: December 11, 2011, 05:16:33 pm »
hmm? It says in the notes for 0.58 rc3 that hight res levels are available...

EDIT: Tested it with both 0.59 and 0.58, both used the low res level. Couldn't find anywhere in options where it could be tweaked either (checked at unstable level.)
« Last Edit: December 11, 2011, 05:42:11 pm by Gaston »
Logged
26 Mars 2007
Belle: woah, is that a neatly snuck in sexproposition? Could I ask you to take of your pants?

Gaston

Re: [Release] OpenLieroX 0.58 rc
« Reply #50 on: December 14, 2011, 10:22:06 pm »
Anyone know anythig about this?
Logged
26 Mars 2007
Belle: woah, is that a neatly snuck in sexproposition? Could I ask you to take of your pants?

DarkCharlie

Re: [Release] OpenLieroX 0.58 rc
« Reply #51 on: December 17, 2011, 04:42:31 pm »
Hmm, it should be supported and OLX should detect it automagically. Do you have a sample level that doesn't work?
Logged

Gaston

Re: [Release] OpenLieroX 0.58 rc
« Reply #52 on: December 17, 2011, 05:25:17 pm »
Yeh, here. I used Pelyas tool to compile it.
Logged
26 Mars 2007
Belle: woah, is that a neatly snuck in sexproposition? Could I ask you to take of your pants?

Gaston

Re: [Release] OpenLieroX 0.58 rc
« Reply #53 on: December 26, 2011, 10:53:01 pm »
So no easy fix for this?
Logged
26 Mars 2007
Belle: woah, is that a neatly snuck in sexproposition? Could I ask you to take of your pants?

DarkCharlie

Re: [Release] OpenLieroX 0.58 rc
« Reply #54 on: December 28, 2011, 03:19:00 pm »
Sorry, took some time before I got to it. The problem is with Pelya's tool, it creates corrupted files. There's a newer version (at least in the code repository) of the tool, I'll try to compile it and put it online.

EDIT: it is online now, download all the files from the distrib repository and run the exe.
« Last Edit: December 28, 2011, 05:47:25 pm by DarkCharlie »
Logged

Gaston

Re: [Release] OpenLieroX 0.58 rc
« Reply #55 on: December 29, 2011, 12:50:01 am »
Hmmpf, I can't get it to work. Windows keeps nagging me that it's not compatible with this version etc. I'm running a 64 bit version though, so I'll check if it works on 32 bit.

nevermind. Seems I managed to download the html source and save it as the file.

EDIT: Downloaded it, and it compiled fine. The resulting level though has some very noticable bugs. Everyedge where rock meets air, there's black and grey ugly big pixels (as in they look like they're low-res compared to the rest of the level.) I've deduced as smuch as that they must be an artifact of some misalignment with the background and foreground file with the material file (I'm making solid stuff grey in bg file, and air black in fg file.) I've had a few tries, and it seems impossible to completely eliminate these artifacts, and it seems to come out of the problem that the low-res material file always loses information. So a fix to this must be something like allowing a high-res material file along with the low-res material file. So the only way to make non-ugly high-res levels is to not grey/black out the areas that are rock/air, and thus we get somewhat higher sizes on levelfiles.
« Last Edit: December 29, 2011, 01:30:13 am by Gaston »
Logged
26 Mars 2007
Belle: woah, is that a neatly snuck in sexproposition? Could I ask you to take of your pants?

DarkCharlie

Re: [Release] OpenLieroX 0.58 rc
« Reply #56 on: December 29, 2011, 02:26:11 pm »
Could you please attach the level file? I'm working on the final 0.58 release ATM and the artifacts should be fixed.
Logged

Gaston

Re: [Release] OpenLieroX 0.58 rc
« Reply #57 on: December 29, 2011, 08:47:23 pm »
Sure
Logged
26 Mars 2007
Belle: woah, is that a neatly snuck in sexproposition? Could I ask you to take of your pants?

Gaston

Re: [Release] OpenLieroX 0.58 rc
« Reply #58 on: January 08, 2012, 01:48:08 am »
btw, if it's not a big hassle to implement, there's a few features for the race mode that could really make it awesome/popular:

- A countdown at the start. Right now it just starts out of the blue
- Possible to not allow ropehooks on other worms
- leaderboard that's always visible during race
- laptime and racetime being recorded.
Logged
26 Mars 2007
Belle: woah, is that a neatly snuck in sexproposition? Could I ask you to take of your pants?

DarkCharlie

Re: [Release] OpenLieroX 0.58 rc
« Reply #59 on: January 10, 2012, 07:08:05 pm »
That sadly is quite a hassle to implement and would need changes in the network protocol. I'll skip it for the final 0.58, but please fill a feature request for 0.59 if you haven't already :)
Logged

IRC

Re: [Release] OpenLieroX 0.58 rc
« Reply #60 on: January 11, 2012, 03:06:30 pm »
My problem is i can't join N/A ping servers, but when i used proxy server it worked, why is tat.
Logged
Cop is my legacy.

Raziel

Re: [Release] OpenLieroX 0.58 rc
« Reply #61 on: January 11, 2012, 03:43:40 pm »
That sadly is quite a hassle to implement and would need changes in the network protocol. I'll skip it for the final 0.58, but please fill a feature request for 0.59 if you haven't already :)


This made me wonder now ^^

So is it going to be like 0.58; 0.59; 0.60; 0.61; 0.62; 0.63... 0.99 to finally realse 1.0? :D Kinda cool, I admire your long term determination heeehee.
Logged
Yes, it's Raziel.

Hatten

Re: [Release] OpenLieroX 0.58 rc
« Reply #62 on: February 22, 2012, 12:49:18 pm »
That sadly is quite a hassle to implement and would need changes in the network protocol. I'll skip it for the final 0.58, but please fill a feature request for 0.59 if you haven't already :)


This made me wonder now ^^

So is it going to be like 0.58; 0.59; 0.60; 0.61; 0.62; 0.63... 0.99 to finally realse 1.0? :D Kinda cool, I admire your long term determination heeehee.
Or why not do it like minecraft? 0.99; 1.00; 1.01; ... ; 1.9 ; 1.0.0!
Logged
I don't do unintentionall mistakes.
Pages: 1 2 3 4 [All]   Go Up
 

anything